Coderz.PRO

Hilfe zu Programmier-/Skriptsprachen für Anfänger und Profis. Zusätzlich Support zu WBB/WCF und -Plugins.

Nachrichten

  • Neu

    ich habe vo kurzem das neuste Xampp Paket installiert.
    In der vorherigen Version konnte ich alles aus dem htdocs Verzeichniss starten und installieren.

    Jetzt geht`s nicht mehr
    http://localhost/wbb4_test/install.php
    > Eror 404


    Was mache ich nur falsch!?
    PHPmyAdmin lässt sich ohne stress starten und Datenabnken anlegen geht auch.

    Nachtrag
    Hat sich erledigt
    sowas dämliches! War im falschen(alten) htdocs Verzeichenis

Ungelesene Themen

Thema Antworten Letzte Antwort

Benutzer-Avatarbild

[curl]Fileupload Problem

Freaky - - PHP, MySQL
22
Benutzer-Avatarbild

Freaky

Benutzer-Avatarbild

WBB4 lässt sich aus dem /htdocs nicht starten

kons - - Software
0

Letzte Aktivitäten

  • Benutzer-Avatarbild

    Freaky -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Doch grundsätzlich geht ja alles. Dein Script geht ja auch bei mir aufm Webspace. Naja egal, ich versuche es mal selbst nachzubauen und vll finde ich ja den Grund dazu :) Ich vermute auch, wieso mein Script nicht funktioniert hat, liegt daran, dass ich…
  • Benutzer-Avatarbild

    kons -

    Hat das Thema WBB4 lässt sich aus dem /htdocs nicht starten gestartet.

    Thema
    ich habe vo kurzem das neuste Xampp Paket installiert. In der vorherigen Version konnte ich alles aus dem htdocs Verzeichniss starten und installieren. Jetzt geht`s nicht mehr http://localhost/wbb4_test/install.php > Eror 404 Was mache ich nur…
  • Benutzer-Avatarbild

    FirePanther -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Vielleicht keine rechte für die Textdatei? Oder andere Rechte, allow url fopen oder was anderes in der php.ini? Weiß leider nicht.
  • Benutzer-Avatarbild

    Freaky -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Sehr komisch ... local gehts nicht. Aufm Server gehts :D Danke :) Jetzt frage mich aber, wieso ging es bei meinem Script nicht?
  • Benutzer-Avatarbild

    FirePanther -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Hm, kann es nicht reproduzieren, bei mir funktioniert es. Kommentier mal den destruct aus, wird eine cookie Datei angelegt?
  • Benutzer-Avatarbild

    Freaky -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    nVp Das was ich mit der Maus markiert habe gibt ein nichts wieder, leer. Genauso wie das gelbe.
  • Benutzer-Avatarbild

    FirePanther -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Bis followloc... Ist doch alles ok, nur fehlt der location header. Deshalb den Parameter von followloc... Ausgeben, oder hast du schon?
  • Benutzer-Avatarbild

    Freaky -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Der gute Herr hat mich falsch verstanden :( Bevor followLocation aufgerufen wird, wird der Quelltext nach dem Uploaden an die Funktion weitergegeben. Leider ist dieser Quelltext leer.
  • Benutzer-Avatarbild

    FirePanther -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Dann mach mal print_r $headerParts über der foreach Schleife
  • Benutzer-Avatarbild

    Freaky -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    hmm sehr eigenartig. Also bei mir ist es jedenfalls so, dass in Zeile 79 nichts zurück gegeben wird und dadurch die Fehlermeldung von Zeile 102 anspringt. Ich habe jetzt nicht das tollste Aufnahmewerkzeug gehabt, aber man sieht den Fehler :D
  • Benutzer-Avatarbild

    FirePanther -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Hi, Zeile 102 kann gar nicht sein. Hast du exakt mein Skript benutzt? Bitte genaue Fehlermeldung posten.
  • Benutzer-Avatarbild

    Freaky -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Ja die \n müssen durch Zeilenbrüche ersetzt werden, sonst gehts nicht :D Ich bekomme leider ein Fehler in Zeile 102 bei deinem Script. Das kommt aber dadurch, wenn du das Bild hochlädst, dass da keine Antwort zurück kommt (jedenfalls bei mir).
  • Benutzer-Avatarbild

    FirePanther -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    diese wird nur durch new Date als String gebildet: f.RequestID=(new Date).getTime().toString(); es ist unwahrscheinlich, dass das geprüft wird, aber ich habe es trotzdem mal richtig eingebaut (also mit der millisekundenanzahl) ansonsten habe ich es mal…
  • Benutzer-Avatarbild

    Freaky -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Das habe ich jetzt hinbekommen :P Nur das Problem jetzt ist, ich weiß nicht ob es wirklich erfolgreich hochgeladen wurde oder nicht. Am Ende beim hochladen des Bildes kommt eine Bestätigung als Link die man aufrufen muss (vermute ich). Das sieht so aus:
  • Benutzer-Avatarbild

    FirePanther -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    hi, ja natürlich musst du dich vorher einloggen und die cookies speichern :D tolle Fehlermeldung von Ask, wenn man nicht eingeloggt ist, gar nicht hilfreich :P
  • Benutzer-Avatarbild

    Freaky -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Nope, bekomme immer noch den selben Fehler. Wenn ich den HTML Teil von oben benutze und mir via PHP anzeigen lasse, was der Server bekommt, dann stimmt alles :o Es geht um diese Seite: ask.fm Testaccount: xxemily_lol_11xx Passwort:…
  • Benutzer-Avatarbild

    FirePanther -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    eine von denen definierte fehlermeldung wahrscheinlich. versuch es mal mit folgendem: PHP-Quellcode (5 Zeilen) kannst auch den link zum avatar upload senden, falls es nicht funktioniert
  • Benutzer-Avatarbild

    Freaky -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Der Pfad ist schon richtig :D Die [] sind schon nach deinem ersten Post weg und habe es mal ausgegeben: [:error, "Objectspec identifier missing"] Was heißt das?
  • Benutzer-Avatarbild

    FirePanther -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    wenn du das mit dem $path gemacht hast, schreib mal in der nächsten zeile nur zum test: die(is_file($path) ? "OK" : "Fehler"); und mach die eckigen klammern weg, das ist eher für multiple files und was genau gibt curl_exec aus (nicht zurück, sondern…
  • Benutzer-Avatarbild

    Freaky -

    Hat eine Antwort im Thema [curl]Fileupload Problem verfasst.

    Beitrag
    Die [] sind da, weil ich es auf irgend einer Internetseite gelesen habe. Habe beides mal ersetzt und probiert ... das Bild wird einfach nicht hochgeladen :( Muss ich denn eigentlich boundary mit irgend wie einbauen? Habe jetzt folgendes gefunden:
Botcheck